Controlli Ambiente in SG Optimizer

Come utilizzare HTTPS, PHP, GZIP e le opzioni di caching del browser per ottenere le migliori prestazioni

Controlli HTTPS

Importante! Prima di abilitare l'HTTPS, è necessario avere un certificato SSL emesso per il dominio del sito. Per impostazione predefinita, SiteGround genera i certificati gratuiti Let's Encrypt per tutti gli account. Per verificare se ce n'è uno emesso per il tuo dominio WordPress, puoi utilizzare il nostro strumento  Let’s Encrypt nel CPanel.

Una volta rilasciato il certificato SSL, è possibile abilitare l'HTTPS tramite il SG optimizer. Questo configurerà il tuo sito per funzionare correttamente tramite HTTPS e forzerà una connessione sicura ad esso aggiungendo una regola nel tuo file .htaccess. L'esecuzione del tuo sito tramite HTTPS rende anche il tuo sito più veloce, in quanto solo il sito HTTPS può beneficiare del protocollo HTTP2 innovativo e più veloce disponibile su tutti i nostri server.

Dopo aver abilitato l'HTTPS, vedrai un'altra opzione - Correggi il contenuto non sicuro. Nella maggior parte dei casi questo non ha bisogno di essere acceso. Usalo solo se noti avvisi di contenuto non sicuri / misti sul tuo sito dopo aver impostato l'HTTPS. Questa opzione riscrive dinamicamente le risorse caricate in modo insicuro per passare attraverso https. Anche se abbiamo sviluppato la riscrittura per essere super veloce, aggiungerà un sovraccarico non necessario al processo di caricamento del tuo sito se è già configurato e funziona correttamente tramite HTTPS.

Controlli per le Versioni PHP

Di solito, le nuove versioni di PHP migliorano le prestazioni dei siti Web di WordPress. Questo è il motivo per cui abbiamo aggiunto una semplice opzione per cambiare la versione PHP nel nostro plug-in SG Optimizer.

Se non stai ancora utilizzando la versione PHP che ti consigliamo, SG Optimizer ti permetterà di verificare se il tuo sito è compatibile con essa. Nel caso lo sia, sarà possibile passare alla versione consigliata con un click. Nel caso in cui si ottengano segnalazioni sul fatto che alcuni plug-in / temi non funzionano con la versione PHP consigliata, è necessario contattare gli sviluppatori di plug-in / temi per ottenere maggiori informazioni su quando il loro prodotto sarà pronto per questa versione di PHP.

Oltre alla funzionalità di controllo e modifica della versione PHP raccomandata sopra, ti permettiamo anche di passare manualmente a qualsiasi versione PHP supportata sui nostri server. Se è necessario utilizzare questa opzione, procedere con cautela poiché non ha un controllo di compatibilità e il passaggio a una versione PHP incompatibile potrebbe rendere inaccessibile il tuo sito web. Tuttavia, puoi sempre tornare indietro usando lo strumento Gestione Versione PHP nel cPanel.

Compressione GZIP

Questo è un meccanismo per comprimere i tuoi contenuti prima di trasmetterli ai browser dei tuoi visitatori. Risparmia molto traffico di rete e velocizza il caricamento del tuo sito. Nota che questa opzione aggiunge regole al tuo file .htaccess, quindi ti invitiamo a rimuovere tutte le regole relative a GZIP esistenti se ne hai già aggiunte manualmente.

Cache del Browser

Abilitando questa opzione, il nostro plugin aggiungerà le regole necessarie al tuo file .htaccess per assicurarti che i browser dei tuoi visitatori memorizzino il contenuto statico nella cache il più a lungo possibile, rendendo il caricamento del tuo sito incredibilmente veloce per i visitatori che tornano al sito.