Inizio
/
WordPress
/
Domande frequenti
/
Come correggere il loop "È richiesto l'aggiornamento del database" su WordPress

Come correggere il loop "È richiesto l'aggiornamento del database" su WordPress

Dopo aver aggiornato WordPress ad una nuova versione, un messaggio potrebbe apparire quando provi a fare login nel wp-admin:  “È richiesto l’aggiornamento del database“. Questo messaggio ti porta ad aggiornare il database di WordPress, ma quando clicchi su “Aggiorna database di WordPress” ricevi  il messaggio “Non è necessario alcun aggiornamento“. Allora riprovi ad effettuare il login al wp-admin ed il messaggio “Aggiorna database di WordPress” compare nuovamente impedendoti di effettuare l’accesso al pannello amministrativo.

Per risolvere, trova il file chiamato object-cache.php e contenuto nella cartella wp-content della tua installazione WordPress, e rinominalo o eliminalo. Questo ti permetterà di accedere al wp-admin senza problemi.

Cancellando o rinominando questo file viene disabilitata la funzione di cache Memcached di qualsiasi plugin tu stia usando per il tuo sito. Se il plugin è il nostro SiteGround Optimizer, puoi riattivare l’uso di Memcached sul tuo sito WordPress seguendo le istruzioni in questo tutorial.

Condividi questo articolo